Home | Register | Contact | Verify Email | FAQ |
Blogs | Photo Gallery | Press Release | Results | RacersAuction.com | HoseheadsClassifieds.com
Hoosier Tire Great Plains | Hoosier Mid Atlantic | Racing Warehouse | Precise Racing | Performance Race Parts | Xtreme Race Parts

Welcome Guest. Already registered? Please Login

 

Forum: Sprint Car Tech Talk (go)
Moderators: BigDog


Records per page
 
Topic: oil pressure Email this topic to a friend | Subscribe to this TopicReport this Topic to Moderator
Page 1 of 1   of  3 replies
crsa305
September 23, 2012 at 07:05:43 PM
Joined: 02/13/2010
Posts: 61
Reply

During the heats and practice my car has good pressure. But for some reason during the A-main when the engine is run for a long time and the temperture i 200 the oil pressure is low. this past race it was down to like ten but when i reved it up the pressure came back. weight is 20-50 any suggestions. i changed the pump which i was pretty sure it was a good pump.




ozzie07
MyWebsite
October 02, 2012 at 11:58:46 AM
Joined: 02/25/2012
Posts: 322
Reply
Down to 10# racing or idling around it was down to 10? All of our motors will be at 5-20 # of oil pressure when hot under yellow but racing it will be back to 70ish

jayvenus
November 23, 2012 at 02:32:29 PM
Joined: 10/20/2008
Posts: 33
Reply
Reply to:
Posted By: crsa305 on September 23 2012 at 07:05:43 PM

During the heats and practice my car has good pressure. But for some reason during the A-main when the engine is run for a long time and the temperture i 200 the oil pressure is low. this past race it was down to like ten but when i reved it up the pressure came back. weight is 20-50 any suggestions. i changed the pump which i was pretty sure it was a good pump.



Check that your oil temperature gauge is accurate...you can put a mechanical gauge in boiling water at 212F...a lot of gauges are not very accurate

 



linbob
December 30, 2012 at 07:47:20 PM
Joined: 03/12/2011
Posts: 1110
Reply
Reply to:
Posted By: crsa305 on September 23 2012 at 07:05:43 PM

During the heats and practice my car has good pressure. But for some reason during the A-main when the engine is run for a long time and the temperture i 200 the oil pressure is low. this past race it was down to like ten but when i reved it up the pressure came back. weight is 20-50 any suggestions. i changed the pump which i was pretty sure it was a good pump.



I do not know if this was a wet sump or a dry sump. We had same problem with a dry sump, sent it in for a fix, and it was a key way that was broken, Hope you do not use the $19.98 oil pumps from china. Take your pump apart and look at pieces. The gears have been known to crack. Good luck





Post Reply
You must be logged in to Post a Message.
Not a member register Here.
Already registered? Please Login





If you have a website and would like to set up a forum here at HoseHeadForums.com
please contact us by using the contact link at the top of the page.

© 2017 HoseHeadForums.com Privacy Policy